Back to overview
ebbot.eu is down
Jan 15 at 08:06am CET
Affected services
ebbot.eu
Resolved
Jan 15 at 08:06am CET
We are currently experiencing an issue affecting the admin interface for ebbot.eu. Troubleshooting is ongoing.
Update 2025-12-15: 08:16 - Everything should be working as expected now.
Affected services
ebbot.eu