Back to overview
Downtime

Some services are down

Mar 25, 2026 at 3:05am UTC
Affected services
ebbot.eu

Resolved
Mar 25, 2026 at 3:28am UTC

The incident involving ebbot.eu being unreachable has been resolved.

Created
Mar 25, 2026 at 3:05am UTC

We are currently experiencing issues with ebbot.eu. We are currently investigating and will update this status with more info.