Back to overview
decreased performance on ebbot.eu
Sep 20 at 06:38am CEST
Affected services
ebbot.eu
Resolved
Sep 20 at 06:38am CEST
We are currently experiencing decreased performance on ebbot.eu. Troubleshooting is in progress.
UPDATE 06:43 - We are back to normal now.
Affected services
ebbot.eu